Announcement

Collapse
No announcement yet.

ESP Electronic Stability Program

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ESP Electronic Stability Program

    If have this icon to come on in your Ss use caution when entering into curves. Mine was on and when I entered a right hand turn the rear end spun around and I went into a guard rail head first. We were not hurt, the Ss is in the shop and luckily there was no on coming traffic.

    Tell your dealer if you are seeing this com on. Alert Polaris put it on the forums. This could cause a serious situation, we got lucky!!!!


  • #2
    My light would come on several times after 5 minutes +/- after warming up.I would have to turn off the ignition and restart for to clear & only to repeat.I took it to the dealer where they had to reset the system.

    Comment


    • #3
      my Polaris also had the light come on after 5 to 10 minutes of driving. When I took it in for the 500 mile check up the service dept. told me it was out of line and that he had to have the wheels straight and than he reset the stabilizer. I have put on another 200 miles and the light has not come back on since. He said hit large pot hole or curbs can cause it to go on. I didn't hit either but maybe they did in shipping as I had front end damage on delivery which Polaris replaced.
      Tim & Ann

      Comment


      • #4
        Thank-You for sharing that important Infomation
        Pat Snow - Blade - Tmac -

        .................................................. ....... tom n carol

        Click image for larger version

Name:	grins1.jpg
Views:	4
Size:	10.5 KB
ID:	4491

        Comment


        • #5
          Thanks for sharing this info.Hope you get your Slingsshot back soon,

          Comment


          • #6
            Originally posted by Tmac View Post
            my Polaris also had the light come on after 5 to 10 minutes of driving. When I took it in for the 500 mile check up the service dept. told me it was out of line and that he had to have the wheels straight and than he reset the stabilizer. I have put on another 200 miles and the light has not come back on since. He said hit large pot hole or curbs can cause it to go on. I didn't hit either but maybe they did in shipping as I had front end damage on delivery which Polaris replaced.
            I hit a pothole in mine and the light came on and has stayed on. Taking it in for for 500 mile service on Thursday and it is on my list of things to fix. Thanks for the info so i can give the service techs a heads up.

            Comment


            • #7
              Me too! Just got my 2016 days ago,no pot holes or bumps and the light comes on after a few minutes of operation.

              Comment


              • #8
                I got my Ss back after the accident yesterday 8/ 14 and hit a freaking pothole today and ruined my right front wheel

                Comment

                Working...
                X